# Troubleshooting

> Solutions for custom virtual channel restrictions and other common automation issues in VMware Horizon environments.

This page explains how to fix issues you might encounter when running automation in VMware Horizon environments.

## VMware Horizon automations stop working after the UiPath virtual channel is blocked

### Observed behavior

Existing VMware Horizon automations that rely on [UiPath Remote Runtime](https://docs.uipath.com/studio/standalone/latest/user-guide/about-uipath-remote-runtime#uipath-remote-runtime) fail: selector generation stops working and UI Automation activities can no longer detect VMware Horizon elements.

### Cause

All custom virtual channels, including the **UiPath virtual channel**, are blocked by default in VMware Horizon environments — even when standard channels (such as audio, clipboard, and printing) are enabled.

### Solution

Add the UiPath virtual channel to the allow list policy:

1. Configure the allow list policy by following the Omnissa (formerly VMware) documentation:
   * [Enabling Virtual Channel Allow List in Horizon Agent](https://kb.omnissa.com/s/article/84156)
   * [Adding a Virtual Channel to the Allow List in Horizon Agent](https://kb.omnissa.com/s/article/84264)
2. Add the following value to the allow list policy, replacing `<UiPathRemoteRuntime-Install_Path>` with your install location:

   `UIPRDP,<UiPathRemoteRuntime-Install_Path>\UiPathRemoteRuntime.exe`

   For example:

   `UIPRDP,C:\Program Files (x86)\UiPath\RemoteRuntime\UiPathRemoteRuntime.exe`
3. Restart your active VMware Horizon connections for the changes to take effect.
